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[bookmark: _Toc28863400]Introduction
[bookmark: _Toc28863401]Lab overview
In the labs for this course, we will use the STM32F7 Discovery Kit to practice digital signal processing concepts and explore some of their applications using advanced hardware.
Some tasks in the labs for this course require you to run example programs on the STM32F7 Discovery Kit. Therefore, you will need to install a suitable development environment on a host PC. This document describes the steps necessary in order to install and configure the Keil MDK-Arm IDE for use with the STM32F7 hardware platform and to start running the example programs.
The instructions in this guide assume that all software is installed in default locations or at the locations specified explicitly in this document. It is beyond the scope of these instructions to anticipate other possible working configurations. Also, it is quite possible that a working configuration may be achieved by different means than described here, but the procedures described in this document have been tested successfully on Windows 10.

[bookmark: _Toc17900023][bookmark: _Toc5031133][bookmark: _Toc28863402]Requirements
[bookmark: _Software_requirements][bookmark: _Ref12007680][bookmark: _Ref12007694][bookmark: _Ref12007704][bookmark: _Toc12529014][bookmark: _Toc28863403]Software requirements
The following table is a list of required software tools that you need for the labs.
	Software
	Website
	Version1

	Keil MDK-Arm
	https://www.keil.com/arm/mdk.asp

	v5.28 or the latest version

Note: The licensed version of Keil-MDK is needed due to the code size in the programs for this lab. For more information, see https://www2.keil.com/mdk5/selector.

	MATLAB
	https://mathworks.com/downloads/

	R2019a or the latest version

	GoldWave
	https://www.goldwave.com/release.php

	v6.41 or the latest version

	Example programs and ancillary files
	Provided with labs
	Note: The example programs used in this lab were tested using the STM32F7 Device Family Pack (DFP) version 2.9.0 of Keil MDK-Arm.


[bookmark: _Ref12007805]Table 1: Software tools and versions
1 The software versions listed here are versions that we have verified to be working with our labs. You can use the latest available (and most stable) versions of the software if backward and forward compatibility is supported.
[bookmark: _Toc12529015][bookmark: _Toc28863404]Hardware requirements
[bookmark: _Hlk17102840]You will need the STM32F746G Discovery board for these labs.
	Hardware
	Additional Information

	STM32F746G Discovery board
	This is the board that will be used to run the programs in the lab exercises.

In some optional exercises, you will need 2 Discovery boards.

The board can be found at: https://www.st.com/en/evaluation-tools/32f746gdiscovery.html

	Oscilloscope
	This will be necessary for numerous exercises for various uses such as time measurements of output signals.


	Signal Generator
	Needed for some exercises that require a generated input signal.


	BNC T-Piece
	Used to split the signal generator output that will be necessary in some exercises.

	Earphones/Headphones with a microphone
	This will be used in some exercises to listen to signals/input sound signals.

	3.5 mm Audio Jack(s)
	Used to connect various peripherals to the Discovery board.


Table 2: Hardware requirements

[bookmark: _Toc28863405]Overview of STM32F746G Discovery board
The STM32F746G Discovery board features a Cirrus Logic WM8994 stereo audio codec, which is accessed via I2C for control and I2S, using the STM32F746G microcontroller’s serial audio interface (SAI) peripheral, for data. Analogue input and output signals are accessible via two three-pole (TRS) 3.5 mm jack sockets (LINE IN (CN11) and HEADPHONE OUT(CN10)).
As configured for these exercises, the WM8994 converts an analogue input signal into 16-bit signed integer sample values and the DAC converts 16-bit signed integer sample values into an analogue output signal.
Additionally, the WM8994 has a digital microphone interface, and the STM32F746G Discovery board provides two MEMS microphones as input devices.
Some of the hardware features of the STM32F746G Discovery board are highlighted in Figure 1.
[image: ]
[bookmark: _Ref17102866]Figure 1: STM32F746G Discovery board

Note: For this course lab exercises, JP1 should be set to “5V link USB + 5V.” JP2 should be left open.

[bookmark: _Toc28863406]Setting Up Keil MDK-Arm Project
[bookmark: _Download_and_install][bookmark: _Toc28863407]Download and install Keil MDK-Arm
Keil MDK-Arm is the development environment from which executable code will be built and downloaded to the Arm Cortex-M4 processor on the Pioneer Kit.

Due to the size of the example programs in the labs, you will need a license for Keil MDK-Arm. You cannot run the example programs using the code size-limited free version.

To set up Keil MDK-Arm, follow these instructions:

1. Download MDK-Arm from the URL link shown in Software requirements.
2. Install Keil MDK-Arm by running the downloaded executable file (e.g., MDK523.exe) and following the instructions. The files downloaded will, by default, be installed at C:\Keil_v5.
3. Ensure that the Pack Installer is launched as shown in Figure 2. Note that following successful installation, the Pack Installer window may open automatically. Otherwise, you will need to launch the Pack Installer yourself by clicking on the Pack Installer button [image: ] in the Keil MDK toolbar.
4. In the Pack Installer window:
a. Select the Devices tab on the left of the window and select STMicroelectronics > STM32F7 Series > STM32F746 > STM32F746BG > STM32F746BGTx
b. Select the Packs tab on the right of the window and make sure that the following are installed or up-to-date:
· Arm::CMSIS
· Keil::STM32F7xx_DFP. The example programs in this lab were tested using version 2.9.0 of the STM32F7_DFP. If you want to use the most up-to-date DFP version, we strongly recommend that you also install version 2.9.0 as well so that you have a reference in case you are missing some driver files.
· Keil::MDK-Middleware
[image: ]
[bookmark: _Ref17105720]Figure 2: Snapshot of Pack Installer window
[bookmark: _Toc17900030][bookmark: _Toc17900031][bookmark: _Toc17900032][bookmark: _Toc28863408]Install the example program files supplied with the DSP Education Kit
The labs come with example programs that will be used in the labs. These example programs were developed as extensions to the Device Family Pack (DFP) based on its BSP examples and rely on it.
The example programs are intended to be installed within the same location where you installed the STM32F7xx_DFP pack in Download and install Keil MDK-Arm. Note that the example project file supplied with the labs has relative path names set up in the Keil Target Options, and these rely on the pack location relative to driver files supplied as part of the DFP. Alternative installation locations may be possible, but this was not tested for this lab.

Although the default Keil installation path is in C:\Keil_v5, you will need to check where the packs you installed in Download and install Keil MDK-Arm are located. The Pack Installer window tile pane in Figure 2 usually indicates this. For example:

 <username>


Note: 
· The example programs were tested using version 2.9.0 of the STM32F7_DFP.
· If your pack installation folder is in AppData, to access the folder, you will need to enable your windows explorer to display hidden files. To do this, in your Windows Explorer, go to the View tab and select the checkbox for Hidden items.

To install the example program files, follow these steps:
1. Navigate to <your pack installation folder>\Keil\STM32F7xx_DFP\2.9.0\Projects\STM32746G-Discovery\Examples
2. Copy the DSP Education Kit folder into the Examples, alongside folders including ADC, BSP, CEC, etc., as shown in the following figure.


[image: ]

Figure 3: File location for example program installation

[bookmark: _Toc28863409]Replace some DFP driver files
A number of features of the STM32F746 and of the Discovery board that are used in the example programs are not implemented or provided for by version 2.9.0 of the DFP, and for this reason, a small number of replacement files are provided as part of the DSP Education Kit. This facilitates the function of the example programs by addition to, modification of, and also in some cases by diminution of DFP driver files provided by STMicroelectronics. Their use for more general program examples other than the DSP Education Kit cannot be guaranteed.

Note: The example programs were tested using version 2.9.0 of the STM32F7_DFP. The functionality that was not catered for by version 2.9.0 of the DFP includes:

· Using the line input (as opposed to the digital microphone input) to the WM8994 codec.
· Implementing multi-buffered (ping-pong) DMA transfers (between the WM8994 codec and the STM32F746).
· Using SAI interrupts to implement sample by sample transfer of data (between the WM8994 codec and the STM32F746).

Therefore, you will need to replace some files in the DFP pack folder by following these steps:

1. Navigate to <your pack installation folder>\Keil\STM32F7xx_DFP\2.9.0\Drivers
2. Replace the following driver files with the ones (similarly named) provided with the DSP Education Kit in Replacement_Files folder as shown in the following table:


	Location
	File(s)

	Drivers\BSP\Components\wm8994
	wm8994.c
wm8994.h

	Drivers\STM32F7xx_HAL_Driver\Src
	stm32f7xx_hal_sai.c

	Drivers\STM32F7xx_HAL_Driver\Inc
	stm32f7xx_hal_sai.h

	Drivers\BSP\STM32746G-Discovery
	stm32f746g_discovery_audio.c
stm32f746g_discovery_audio.h
stm32f746g_discovery.c
stm32f746g_discovery.h


Table 3: Replacement file locations

[bookmark: _Toc17900035][bookmark: _Toc28863410]Install the STLink USB driver
The STLink USB driver enables communication using USB between Keil MDK-Arm and the STM32F407 Discovery.
The STLink USB driver can be found at C:\Keil_v5\ARM\STLink\USBDriver. Execute either dpinst_amd64 (64-bit version) or dpinst_x86 (32-bit version).

[bookmark: _Toc17900037][bookmark: _Toc28863411]Running the project
To ensure successful installation and setup of the Arm Keil MDK for the DSP lab, we shall run the project file that is provided with the DSP Education Kit by following these steps:
1. Ensure you are using a licensed version of Arm Keil MDK. Due to the code size, compiling the code will not work on the Arm Keil MDK Lite version.
2. Navigate to the copied DSP Education Kit\MDK-Arm\ folder and double-click on the DSP_Education_Kit.uvprojx file. You should see a project structure similar to that shown in Figure 4. The project should contain the example file stm32f7_sine_lut_intr.c, which contains the main() function.

[image: ]
[bookmark: _Ref18048037]Figure 4: Screenshot of MDK-Arm showing DSP_Education_Kit project
3. Connect the STM32F746 Discovery board to the host PC using a USB A to mini-b cable.
4. Plug the headphones into the output audio jack socket (CN10) on the board.
5. Build the project by selecting the Project > Build target or by clicking on the Build toolbar button [image: ].

Note: If you are using a different DFP pack version, you may encounter errors where the program is not able to locate certain files. If you encounter this, you may want to go to the Pack Installer and install the version 2.9.0 of Keil::STM32F7xx_DFP, locate the missing files in the 2.9.0 folder, and copy them over to the appropriate directory.

6. Ensure that the correct debugger is selected in Keil MDK by following these steps:
a. Select Project > Options for Target.
b. Open the Debug tab in the Options for Target window.
c. On the right side of the Debug tab, select the driver for the debugger on the Use dropdown menu.
d. Select ST-Link Debugger.
7. After successfully building the project with no errors, switch to the debugger mode (and download the executable code into flash memory) by clicking on the Start/Stop Debug Session toolbar button [image: ].
8. Once the Debugger View has appeared, click on the Run toolbar button as shown in the following figure:

[image: ]
Figure 5: Snapshot of debugger view

Expected results
Once the program is running, you should see a start screen on the LCD on the board showing the program name as shown in the following figure.
[image: ]
Figure 6: Start screen on LCD
Press the User Button shown in Figure 1. You should get a 1 kHz tone output on the HEADPHONE OUT socket on the Discovery board and the following display.
[image: ]
Figure 7: 1 kHz tone display on LCD

[bookmark: _GoBack]If you want to run different example programs, simply replace file stm32f7_sine_lut_intr.c in the MDK-Arm project with another source file. All of the source files are in the DSP Education Kit\Src folder. Detailed instructions for the different program examples are contained in the laboratory exercise manuals.
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