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[bookmark: _Toc49297175]Introduction
In this lab, we will look at how to develop an augmented reality (AR) application using Unity and the frameworks shown in the lecture. By the end of this lab, you will be able to place and control digital components in the real world through a mobile application.
[bookmark: _Toc49297176]Set Up
Please check that your mobile device is supported by the AR CORE KIT before doing this lab.

The first thing that we will do is create a new project for our AR app. Bring up the Unity Hub > New > Create.
[image: ]






On the Unity windows editor, go to Window > Package Manager > Click the drop-down menu > Choose All packages > look for AR Foundation and install it.












For the AR Foundation framework to work correctly, you will need to install the ARCORE XR Plugin and Update the XR Legacy Input Helpers.
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XR Plugin Management should be installed; otherwise, do it manually.
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Go to File > Build Settings > Switch Platform to Android.
Then, go to Player Settings > Player > Other Settings > Tick Auto Graphics API and select API level 24 as the minimum API version.
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Next, go to XR Plug-in Management and tick ARCORE in Plug-in providers.
[image: ]

Close the project settings, Build Settings, return to main scene, and delete the Main Camera.
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[bookmark: _Toc49297177]Creating AR Session
A basic AR application will need to have an AR session and an AR Session Origin in their main scene. To add them, right-click on your scene XR>AR Session and then do the same for the AR Session Origin.
[image: ][image: ]
Create two folders in your Assets folder and call them Textures and Prefabs.
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Copy 8k_earth_daymap.jpg and Earth.fbx from the lab resources into Textures and Prefabs folders, respectively.
[image: ][image: ]





[image: ]Place the earth prefab in the scene.







As you can see, there is a problem with the lighting. To fix this, we will need to go to Window > Rendering > Lighting Settings > Debug Settings > Tick Auto Generate General Lighting.
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[image: ]


  




[image: ]Now, apply the imported texture to the Earth.fbx by selecting the prefab and dragging the texture onto it.



Now, expand the AR Session Origin > click on the AR Camera object > Inspector > Tag it as Main Camera.
[image: ][image: ]
Double-click on the AR Camera object and you should be able to locate it in the Scene view.
[image: ]
AR Camera will match the rear camera of your mobile phone when you launch the application. Now, what we would like to do is to place our prefab around 1 meter away from our smartphone with a suitable scale. To do that, go to Earth prefab > inspector > position the prefab at (0, 0, 1.25) and scale down the asset by (0.25, 0.25, 0.25). Be careful of getting confused with the children of Earth (Earth and Sun); otherwise, you might need to use a different scale.
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In Unity, 1 meter in real life is translated to 1 unity unit or one of the faces of a cube. Since the AR camera should be in the origin by default (0, 0, 0), we just need to move 1.25 units in the z-axis, taking into consideration the radius of the earth prefab.
If you want to check this by yourself, change the perspective of the view scene to y by clicking in the view tool and placing a GameObject cube as a reference; to do this, go to GameObject > 3D Object > Cube. Don’t forget to delete the cube once you have checked this.
[image: ]
[image: ] 

The earth prefab already contains a source of light, so we can tick off the Directional Light for now.
[image: ] 







Now let’s add a rotation animation contained in the earth assets; go to your Prefabs folder > expand the earth asset > select Scene and press Ctrl + D to make a duplication of this animation.
[image: ][image: ]





Select the Scene animation that has been created > inspector > tick Loop time.
[image: ]







Select Earth prefab > inspector > drag the Scene animation into it, which should generate an animator component along with a controller in the Prefabs folder.
[image: ]










Double-click on the earth controller to see the animator view and check that transition from entry state to the Scene animation as in the following picture.
[image: ]
At this point, you can play the Unity editor to check whether the animation is being played.
[image: ]

Save your scene (CTRL + s) and connect your phone to your computer. In Unity, go to File > Build and Run > write a name for the apk and save it.
Once your application has been built, it should start automatically in your smartphone. You might need to enable USB debugging when USB is connected in the phone Settings, in case you have not done while doing the other labs.
Since it’s the first time launching this application, it will ask for permissions to take pictures and record videos; allow it, and you should be able to see Earth 1 meter away from you. Notice that the earth should keep its position when moving around the environment.
[image: ][image: ][image: ]
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AR foundation allows you to detect Point Cloud (a point cloud is a set of data points in a space as a result of the reconstruction of an environment that will help us to render an object properly in the real world); to do this, select your AR Session Origin > Add component (in Inspector tab) > Search for AR Point Cloud Manager and click on it.
[image: ]   









To visualize this, we will need to add a prefab; right-click in the hierarchy window > XR > AR Default Point Cloud.
[image: ][image: ] 

Open the Prefabs folder and drag the AR Default Point Cloud GameObject in the hierarchy window into the Prefabs folder so that it generates a prefab of this.
[image: ]
  



Delete the AR Default Point Cloud prefab from the hierarchy window and add the generated prefab into the AR Point Cloud Manager Script. You could do this by either dragging the prefab into the field or clicking on the drop-down menu of Point Cloud prefab option > Select Assets > Select AR Default Point Cloud.
   
[image: ]








Save your scene (CTRL + s). Connect your phone to your computer, and in Unity, go to File > Build and Run. When running your application, you will be able to observe Point Clouds around your environment.
[image: ][image: ][image: ]
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To implement the detection of plane surfaces, we will have to do the same as we did with the Point Cloud; select your AR Session Origin > Add component (in Inspector tab) > Search for AR Plane Manager and click it.
[image: ]  









Right-click in the hierarchy window > XR > AR Default Plane.
[image: ][image: ] 
Let’s change the default material of the AR Default Plane to something else. Go to your “Materials” folder (it should have been generated automatically when applying the texture to the earth prefab) > Right-click > Create > Material. Right-click on the new material > Rename. Rename it to ar_plane.
[image: ]

  

[image: ]Select the material > Inspector tab > Change the rendering mode to Transparent > Click in the albedo colour > Add the RGB value (0, 145, 189) or in hexadecimal 0091BD and change alpha value to 119.
[image: ][image: ]







Select the AR Default Plane GameObject in the hierarchy window and change the material for the one that we have modified.













Open the Prefabs folder and drag the AR Default Plane GameObject from the hierarchy window into the Prefabs folder to generate a prefab of this.
[image: ]





Delete the AR Default Plane prefab from the hierarchy window and add the generated prefab into the AR Plane Manager Script (you can tick off AR Point Cloud Manager Script if you want).
[image: ]  
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[image: ][image: ][image: ]Save your scene (CTRL + s). Connect your phone to your computer, and in Unity, go to File > Build and Run. When running your application, you will be able to observe planes around your environment.
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Copy the Model.fbx from the lab resources folder and place it in the Prefab folder.
[image: ]   



Copy the rest of the textures from lab sources in the Texture folder.

[image: ]
 



Create a new prefab; to do this, right-click in the materials window > Create > Material.
Select the new Material > Inspector tab > Click on the circle to the left of “Albedo” > Select WhiteSharkTextBW.png texture.
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In the same inspector tab select Occlusion > Click on the circle to the left of “Occlusion” > Select WhiteSharkAO.png.
[image: ]
Ctrl + s to save.
Go to the Prefabs folder > Select the Model > Inspector tab > Material > add the materials and apply them to the model.
[image: ] 

  












[image: ]Once this is done, drag the model from the Prefabs folder into the hierarchy window; go to Inspector and change its position to (0, 0, 1) and a scale of (0.08, 0.08, 0.08).
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Expand the Model.fbx in the Prefab folder and select the Scene animation and duplicate with Ctrl + D; notice that we still had the Scene animation from the earth, so the duplication should be called Armature_ArmatureAction.
[image: ]  








Select > Armature_ArmatureAction > Inspector tab > Tick Loop Time.
[image: ]


	




Drag the Armature_ArmatureAction into the Model found in the hierarchy window; as it happened with the earth, an Animator should have been generated automatically.
[image: ]











At this point, you can test the animation by pressing play in the unity editor.
[image: ] 







Rename the Model from Hierarchy view to animModel and drag into the Prefabs folder to create an original Prefab.
[image: ]   
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To place an object on our plane, we will need two extra components; select the AR Session Origin > Inspector tab > Add Component > AR Raycast Manager.
[image: ]












Create a new folder in the Assets folder and call it Scripts; inside it, create a New C# Script and name it ObjectPlacement.
[image: ] 

 


Copy and paste the following code in the ObjectPlacement script:
using System.Collections.Generic;
using UnityEngine;
using UnityEngine.XR.ARFoundation;
using UnityEngine.XR.ARSubsystems;


public class ObjectPlacement : MonoBehaviour
{
    //a serialized 
    [SerializeField]
    private GameObject prefabToPlace;
    public GameObject prefabPlaced
    {
        get { return prefabToPlace; }
        set { prefabToPlace = value; }
    }
    public GameObject spawnedObject { get; private set; }

    private Animator animator;

    static List<ARRaycastHit> s_Hits = new List<ARRaycastHit>();

    private ARRaycastManager m_RaycastManager;

    void Awake()
    {
        m_RaycastManager = GetComponent<ARRaycastManager>();
    }
    bool TryGetTouchPosition(out Vector2 touchPosition)
    {
        if (Input.touchCount > 0)
        {
            touchPosition = Input.GetTouch(0).position;
            return true;
        }

        touchPosition = default;
        return false;
    }


    // Update is called once per frame
    void Update()
    {
        if (!TryGetTouchPosition(out Vector2 touchPosition))
            return;
        if(m_RaycastManager.Raycast(touchPosition, s_Hits, TrackableType.PlaneWithinPolygon))
        {
            // Raycast hits are sorted by distance, so the first one
            // will be the closest hit.
            var hitPose = s_Hits[0].pose;
            if (spawnedObject == null)
            {
                spawnedObject = Instantiate(prefabToPlace, hitPose.position, Quaternion.identity);
                animator = spawnedObject.GetComponent<Animator>();
                //let's disable the animator when the object is instantiated 
                animator.enabled = false;
            }
            else
            {
                spawnedObject.transform.position = hitPose.position;
            }
        }
    }

}
Drag this script into the AR Session Origin > Inspector tab. As a result, an Object placement option should appear in the Inspector tab. Then, drag the animModel from your Prefab folder into the “Prefab To Place” field, untick the AR Point Cloud Manager Script, and tick off or delete any model (Earth and animModel) in the Hierarchy window.
[image: ]    
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Before downloading this example to your phone, let’s analyze the code. 


public class ObjectPlacement : MonoBehaviour
{
    [SerializeField]
    private GameObject prefabToPlace;
    public GameObject prefabPlaced
    {
        get { return prefabToPlace; }
        set { prefabToPlace = value; }
    }
    
    public GameObject spawnedObject { get; private set; }

    private Animator animator;









We define a GameObject variable called prefabToPlace to take advantage of the Unity Inspector so that we can make a field to drag and drop our prefab object. It’s a good practice to use private variables in our code to avoid introducing bugs when scaling the project, but if we do this, then the variables wouldn’t appear in the Unity Inspector.
The SerializedField field above our private GameObject prefabToPlace forces private variables to appear in the Unity Inspector, but as a result, you will use a second variable called GameObject prefabPlaced to get and set correctly the private GameObject prefabToPlace.
Next, we will define a GameObject variable called spawnedObject to reference the instantiation of the prefab when tapping on a plane.
We then proceed to add an Animator variable that will help us to play and stop the animation of the object    static List<ARRaycastHit> s_Hits = new List<ARRaycastHit>();

    private ARRaycastManager m_RaycastManager;

    void Awake()
    {
        m_RaycastManager = GetComponent<ARRaycastManager>();
    }
    bool TryGetTouchPosition(out Vector2 touchPosition)
    {
        if (Input.touchCount > 0)
        {
            touchPosition = Input.GetTouch(0).position;
            return true;
        }

        touchPosition = default;
        return false;
    }






 




 

We will use a list of ARRaycastHit called s_Hits to contain raycast results generated from casting a ray from a point in screen space (our mobile screen) against trackables (our detected surface plane).
Then, we will make a private ARRaycastManager variable called m_RaycastManager that should reference our ARRaycastManager component found in the AR Session Origin.
After that, we will make a method to test whether we are pressing our display screen, and if so, we will return a Vector2(x,y) of our touch position.
    void Update()
    {
        if (!TryGetTouchPosition(out Vector2 touchPosition))
            return;




In the void Update method, we will check if we are touching the display screen of the mobile phone; if not, then the function will return. Notice that using return in a void method will exit the method without quitting the program.
  


        if(m_RaycastManager.Raycast(touchPosition, s_Hits, TrackableType.PlaneWithinPolygon))
        {
            // Raycast hits are sorted by distance, so the first one
            // will be the closest hit.
            var hitPose = s_Hits[0].pose;
            if (spawnedObject == null)
            {
                spawnedObject = Instantiate(prefabToPlace, hitPose.position, Quaternion.identity);
                animator = spawnedObject.GetComponent<Animator>();
                //let's disable the animator when the object is instantiated 
                animator.enabled = false;
            }
            else
            {
                spawnedObject.transform.position = hitPose.position;
            }
        }
    }


}













If we are touching the display screen of the mobile phone, then we need to check whether we are tapping on a surface plane. You can do by calling a raycast from the RaycastManager and sending the touchPosition as arguments, a list to store the results of the raycast if successful, and specifying the type of trackable that you are casting against to.
If(m_RaycastManager.Raycast(touchPosition, s_Hits, TrackableType.PlaneWithinPolygon))
If that is the case, then we can take the first element in the s_Hits list and extract its Unity world space coordinates that should be the nearest pose (position and orientation) to where we were tapping in the plane.
var hitPose = s_Hits[0].pose;

Then, check if the object has been instantiated; if not, instantiate the object with Instantiate (prefab, hitposition, rotation). Note that Quaternion.identity means that there will be no rotation. In addition, we will store the reference of this instantiation in the GameObject spawendObject that will help us to get the reference to the Animator controller to stop or play the animation.
if (spawnedObject == null)
{
  spawnedObject = Instantiate(prefabToPlace, hitPose.position, Quaternion.identity);
  animator = spawnedObject.GetComponent<Animator>();
  animator.enabled = false;
}

If there is an instantiation of the prefab already, then we could simply use GameObject SpawnedObject.transform.position to insert the new hit position extracted before.
else
  spawnedObject.transform.position = hitPose.position;
Save your scene (CTRL + s). Connect your phone to your computer, and in Unity, go to File > Build and Run.
In your phone, detect a plane in your environment and tap on the plane to instantiate an object in your environment. When you tap on the plane, a static (non-swimming) shark will appear on the plane.
[image: ]
[image: A picture containing bedroom, table, room, bed
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If the model is too big for your environment, you can scale it down even further; to do this, Select animModel prefab found in the Assets > Prefabs folder (not Hierarchy window) > Inspector tab > Transform > Scale down even further if needed.
[image: ]



  






[bookmark: _Toc48739615][bookmark: _Toc48740654][bookmark: _Toc48740686][bookmark: _Toc49297182]Controlling the Object with a Joystick
The next thing we will do is to control the movement of our object with a joystick that you have seen before in the Chess example of the previous lab.

Go to GameObject > Select UI > click on Canvas
Note: If the earth and animModel gameobject still exist in the Hierarchy window, then you might still see a “floating earth” and a “floating shark” when running in your phone. You can choose to delete these from the hierarchy window.
[image: ]  
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In Canvas, add 2 Image objects and rename them as follows: LeftJoystick, LeftJoystickFixed
[image: ] 
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Copy the JoystickUI folder from the lab resources into your Assets folder and NewJoystick.cs from lab resources into the Scripts folder.
[image: ][image: ]





Select LeftJoystickFixed in Hierarchy window > Open the JoystickUI folder, drag the joystick_fixed sprite, and fill the Source Image field of the LeftJoystickFixed Inspector tab with it. Set the colour to RGBA = 128, 128, 128, 255. Set the Width = 128 and Height = 128, untick Raycast Target, and check its Pos X, Y, Z = (0, 0, 0).
[image: ]

 









Next, let’s work on the LeftJoystick element:
· Drag the joystick sprite into the image field. Set the RGB color value to 128, 128, 128, 255W. Set the Width = 64 and Height = 64, check its Pos X, Y, Z = (0, 0, 0), tick Raycast Target, and add graphic raycaster by selecting Add Component.
· Drag and drop the NewJoystick script from the scripts folder in the project panel to the Inspector of LeftJoystick.
· Specify the joystick type to be Left.
· J Trans Clamp Value =100; Fade Out = 0.1; Fade in = 0; and Hold threshold = 0. 
· Link the LeftJoystickFixed image to the ‘Fixed Joystick img’ field by dragging the LeftJoystickFixed element from the Hierarchy panel.
· Finally, set the UI scale factor to 0.001 and the J Trans values to X = 0 and Y = 0.
[image: ]
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After that, we will add a button to the canvas because of two reasons:
· To disable the continuous detection of planes in the app when we think it is no longer necessary.
· To avoid any interference caused from touching the display between the trackable plane and the joystick.




[image: ]
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Select Button element > Inspector tab > Rect Transform > Click in the square to bring Anchors selection > Press and hold the Alt key and Select center top.
 


  







In the same Inspector tab, change Pos Y to −72 and Height to 42.
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[image: ]Expand the Button element > Select Text > Inspector tab > Change Text to “Lock” and its font size to 32.
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After that, we will do the following modifications to our ObjectPlacement.cs script:
· Add a public GameObject variable to reference the joystick.
· Add a private Vector2 variable to store the x and y coordinates of the Joystick.
· Add a private Vector3 variable to store the new direction of the object according to the joystick coordinates.
· Add a public float variable that will reference the speed of the object.
· Add a public UnityEngine.UI.Button to reference the button in the canvas.
· Add a private ARPlaneManager variable to reference the ARPlaneManager component from the AR Session Origin Game Object.
· Set up the reference of the ARPlaneManager variable in the Awake function as we have done for the RaycastManager.
· Add a private Boolean variable to keep track of two states: Lock and Unlock.
· Set up the Boolean mentioned in the last point to false in the Awake function.
· Add a method to switch between states that will be linked with the button in the canvas.
· Change the text component of the button when switching between states.
· Fix the coordinates of the joystick by multiplying them by −1 in the update function.
· Calculate the direction of the new object in the update function.
· Set up the new movement of the object with the joystick when we are not in Unlock state and when the spawnedObject does not equal null in the update function.
· Notice that in the Lock state, the detection plane will be turned off, placing an object on a plane will not be possible, and the Joystick should be able to modify the position of an existent object in the environment. Otherwise, if we are in the Unlock state, the detection will be turned on, placing an object on the plane should be possible, and the Joystick should not have any effect in any existent object in the environment.

Before looking at the solution, try to implement the modifications by yourself.Hints
To disable plane detection, you can simply use the reference to the ARPlaneManager variable and set is enabled property to false
<ARPlaneManager private variable>.enabled = false

To extract the correct coordinates of the joystick, you can call the joystick, get its component NewJoystick, get its JTrans property, and multiply by −1
<coordinate variable> = <joy>.GetComponent<NewJoystick>().jTrans * -1
  
To calculate the direction of joystick, you can take the x and y coordinates, multiply them by a Vector3.right and Vector3.forward, respectively, and add them together.
<direction private variable> = Vector3.right * <joy coordinate variable>.x + Vector3.forward* <joy coordinate variable>.y 

The new position of the object can be calculated by adding the spawned object and adding the direction times the speed of the object defined times Time.deltaTime
spawnedObject.transform.position += <direction>*<speed>*Time.deltaTime;









Solution
using System.Collections.Generic;
using UnityEngine;
using UnityEngine.XR.ARFoundation;
using UnityEngine.XR.ARSubsystems;


public class ObjectPlacement : MonoBehaviour
{
    //a serialized 
    [SerializeField]
    private GameObject prefabToPlace;
    public GameObject prefabPlaced
    {
        get { return prefabToPlace; }
        set { prefabToPlace = value; }
    }
    public GameObject spawnedObject { get; private set; }

    private Animator animator;

    static List<ARRaycastHit> s_Hits = new List<ARRaycastHit>();

    private ARRaycastManager m_RaycastManager;

    public GameObject leftjoy;

    private Vector2 coordinatesOfJoy;

    private Vector3 directionOfObject;

    public float speedOfObject;

    public UnityEngine.UI.Button lockButton;

    private ARPlaneManager m_ARPlaneManager;

    private bool isInLockingState;

    public void switchState()
    {
        if (isInLockingState == false)
        {
            lockButton.GetComponentInChildren<UnityEngine.UI.Text>().text = "Unlock";
        }
        else
        {
            lockButton.GetComponentInChildren<UnityEngine.UI.Text>().text = "Lock";
        }
        isInLockingState = !isInLockingState;
        m_ARPlaneManager.enabled = !m_ARPlaneManager.enabled;
    }
    void Awake()
    {
        isInLockingState = false;
        m_ARPlaneManager = GetComponent<ARPlaneManager>();
        m_RaycastManager = GetComponent<ARRaycastManager>();
    }
    bool TryGetTouchPosition(out Vector2 touchPosition)
    {
        if (Input.touchCount > 0)
        {
            touchPosition = Input.GetTouch(0).position;
            return true;
        }

        touchPosition = default;
        return false;
    }


    // Update is called once per frame
    void Update()
    {
        if (!TryGetTouchPosition(out Vector2 touchPosition))
            return;
        if (isInLockingState == false)
        {
            if (m_RaycastManager.Raycast(touchPosition, s_Hits, TrackableType.PlaneWithinPolygon))
            {
                // Raycast hits are sorted by distance, so the first one
                // will be the closest hit.
                var hitPose = s_Hits[0].pose;
                if (spawnedObject == null)
                {
                    spawnedObject = Instantiate(prefabToPlace, hitPose.position, Quaternion.identity);
                    animator = spawnedObject.GetComponent<Animator>();
                    //let's disable the animator when the object is instantiated 
                    animator.enabled = false;
                }
                else
                {
                    spawnedObject.transform.position = hitPose.position;
                }
            }
        }
        else
        {
            if(spawnedObject != null)
            {
                coordinatesOfJoy = leftjoy.GetComponent<NewJoystick>().jTrans * -1;
                directionOfObject = Vector3.right * coordinatesOfJoy.x + Vector3.forward * coordinatesOfJoy.y;
                spawnedObject.transform.position = spawnedObject.transform.position + (directionOfObject*speedOfObject * Time.deltaTime); 
            }
        }
    }
}


Once that you have compared your outcome with the solution, return to Unity Editor > AR Session Origin Inspector tab > Object Placement > Fill the new fields that have appeared.
[image: ] 







We will need to link the button from canvas to the method that switches between states; to do this, select Button element > Inspector tab > On click > click in the plus sign > drag the AR Session origin into the None Object. Then, select function > ObjectPlacement > switchState() method for switching between states.
[image: ]
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Save your scene (CTRL + s), connect your phone to your computer, and in Unity, go to File > Build and Run.
Rotate your phone horizontally > detect a plane in your environment > tap on the plane to instantiate an object (the shark) > press the Lock button to lock the shark state.
The joystick should appear on the bottom left corner. Check that you can move the object using your joystick—press, hold, and move the joystick on the bottom left corner of the phone. You will notice that the static (non-swimming) shark will move, and you will notice how the shark can exit the plane where it was instantiated—we will polish this up in the next section.
[image: A picture containing umbrella, bed

Description automatically generated][image: A picture containing umbrella, table, bed

Description automatically generated]



  
[image: A picture containing table

Description automatically generated]
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To end this lab, we will fix and polish the control of the joystick over the object. So far, our object is moving according to our joystick direction, but we will change this so that the movement is relative to the main camera.
Direction depends just on the joystick
Let’s assume you instantiate an object in your plane; if you press the joystick up, the object will move forward according to the direction in which you have instantiated this. What this means is that, if your camera perspective changes, the object will still move according to the first direction that was given at the start without taking into consideration the perspective of the camera. This is bothersome in situations where the camera perspective is changing constantly.
Camera
Camera










Direction depends on the joystick and camera
Whereas in this case, we are taking into consideration the perspective of the camera to calculate the direction, and thus, a new movement of the object
Camera[image: ]
Camera[image: ]


 






To implement this, in the ObjectPlacement.cs script, go to the code line before the new position of spawnedObject is set up, calculate a new direction according to the main camera, set its y position to zero, and replace the joystick direction as shown in the following code
              if(spawnedObject != null)
            {
                coordinatesOfJoy = leftjoy.GetComponent<NewJoystick>().jTrans * -1;
                directionOfObject = Vector3.right * coordinatesOfJoy.x + Vector3.forward * coordinatesOfJoy.y;
                var newdir = Camera.main.transform.TransformDirection(directionOfObject);
                newdir.y = 0.0f;
                spawnedObject.transform.position = spawnedObject.transform.position + (newdir * speedOfObject * Time.deltaTime); 
            }

Next, make the object rotate according to the direction in which we are moving.
      if(spawnedObject != null)
            {
                coordinatesOfJoy = leftjoy.GetComponent<NewJoystick>().jTrans * -1;
                directionOfObject = Vector3.right * coordinatesOfJoy.x + Vector3.forward * coordinatesOfJoy.y;
                var newdir = Camera.main.transform.TransformDirection(directionOfObject);
                newdir.y = 0.0f;
                Quaternion rotation = Quaternion.LookRotation(newdir, Vector3.up);
                spawnedObject.transform.rotation = rotation;
                spawnedObject.transform.position = spawnedObject.transform.position + (newdir * speedOfObject * Time.deltaTime); 
            }   




Then, we will restrict the movement of the object to the plane that has been instantiated.
            if(spawnedObject != null)
            {
                coordinatesOfJoy = leftjoy.GetComponent<NewJoystick>().jTrans * -1;
                directionOfObject = Vector3.right * coordinatesOfJoy.x + Vector3.forward * coordinatesOfJoy.y;
                var newdir = Camera.main.transform.TransformDirection(directionOfObject);
                newdir.y = 0.0f;
                Quaternion rotation = Quaternion.LookRotation(newdir, Vector3.up);
                spawnedObject.transform.rotation = rotation;
                var newPos = spawnedObject.transform.position + newdir;
                var ray = new Ray(newPos, Vector3.down);
                var insidePlane = m_RaycastManager.Raycast(ray, s_Hits, TrackableType.PlaneWithinPolygon);
                if (insidePlane)
                    spawnedObject.transform.position = newPos;
            }
Finally, try to figure how to play/stop the animation of the object when we are moving.
Look at the full solution in case you get stuck with something.

Solution
using System.Collections.Generic;
using UnityEngine;
using UnityEngine.XR.ARFoundation;
using UnityEngine.XR.ARSubsystems;


public class ObjectPlacement : MonoBehaviour
{
    //a serialized 
    [SerializeField]
    private GameObject prefabToPlace;
    public GameObject prefabPlaced
    {
        get { return prefabToPlace; }
        set { prefabToPlace = value; }
    }
    public GameObject spawnedObject { get; private set; }

    private Animator animator;

    static List<ARRaycastHit> s_Hits = new List<ARRaycastHit>();

    private ARRaycastManager m_RaycastManager;

    public GameObject leftjoy;

    private Vector2 coordinatesOfJoy;

    private Vector3 directionOfObject;

    public float speedOfObject;

    public UnityEngine.UI.Button lockButton;

    private ARPlaneManager m_ARPlaneManager;

    private bool isInLockingState;

    public void switchState()
    {
        if (isInLockingState == false)
        {
            lockButton.GetComponentInChildren<UnityEngine.UI.Text>().text = "Unlock";
        }
        else
        {
            lockButton.GetComponentInChildren<UnityEngine.UI.Text>().text = "Lock";
        }
        isInLockingState = !isInLockingState;
        m_ARPlaneManager.enabled = !m_ARPlaneManager.enabled;
    }
    void Awake()
    {
        isInLockingState = false;
        m_ARPlaneManager = GetComponent<ARPlaneManager>();
        m_RaycastManager = GetComponent<ARRaycastManager>();
    }
    bool TryGetTouchPosition(out Vector2 touchPosition)
    {
        if (Input.touchCount > 0)
        {
            touchPosition = Input.GetTouch(0).position;
            return true;
        }

        touchPosition = default;
        return false;
    }


    // Update is called once per frame
    void Update()
    {
        if (!TryGetTouchPosition(out Vector2 touchPosition))
            return;
        if (isInLockingState == false)
        {
            if (m_RaycastManager.Raycast(touchPosition, s_Hits, TrackableType.PlaneWithinPolygon))
            {
                // Raycast hits are sorted by distance, so the first one
                // will be the closest hit.
                var hitPose = s_Hits[0].pose;
                if (spawnedObject == null)
                {
                    spawnedObject = Instantiate(prefabToPlace, hitPose.position, Quaternion.identity);
                    animator = spawnedObject.GetComponent<Animator>();
                    //let's disable the animator when the object is instantiated 
                    animator.enabled = false;
                }
                else
                {
                    spawnedObject.transform.position = hitPose.position;
                    animator.enabled = false;
                }
            }
        }
        else
        {
            if(spawnedObject != null)
            {
                coordinatesOfJoy = leftjoy.GetComponent<NewJoystick>().jTrans * -1;
                if (coordinatesOfJoy.x != 0 || coordinatesOfJoy.y != 0)
                {
                    
                    directionOfObject = Vector3.right * coordinatesOfJoy.x + Vector3.forward * coordinatesOfJoy.y;
                    var newdir = Camera.main.transform.TransformDirection(directionOfObject);
                    newdir.y = 0.0f;
                    Quaternion rotation = Quaternion.LookRotation(newdir, Vector3.up);
                    spawnedObject.transform.rotation = rotation;
                    var newPos = spawnedObject.transform.position + newdir * speedOfObject * Time.deltaTime;
                    var ray = new Ray(newPos, Vector3.down);
                    var insidePlane = m_RaycastManager.Raycast(ray, s_Hits, TrackableType.PlaneWithinPolygon);
                    if (insidePlane)
                    {
                        spawnedObject.transform.position = newPos;
                        animator.enabled = true;
                    }
                    else
                        animator.enabled = false;
                }
                else
                    animator.enabled = false;
            }
        }
    }
}
To end this lab, let’s recognize just the horizontal planes; to do this select AR Session Origin > Inspector tab > AR Plane Manager > Change Detection mode to Nothing and then to Horizontal.
[image: ]











Save your scene (CTRL + s), connect your phone to your computer, and in Unity, go to File > Build and Run.
Rotate your phone horizontally > detect a plane in your environment > tap on the plane to instantiate an object (the shark) > press the Lock button to lock the shark state.
The joystick should appear on the bottom left corner. Check that you can move the object using your joystick—press, hold, and move the joystick on the bottom left corner of the phone. You will notice that the shark can swim and move according to the joystick within the plane.
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